Skip to main content

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: tracey pooh Date: Mar 20, 2006 10:31am
Forum: forums Subject: Re: Mime type returned prevents media enclosure

do you or some folks there know/have wget?
i'm using it today again and verifying that it is serving
the content with the "audio/mpeg" MIME type.
(results below).

notice how the initial "download" page gets automatically redirected to another page where the item actually is.
wget "follows" that 302 and gets the url being told to
redirect to. is it possible whatever you are using to
determine it is returning "text/plain" is not processing
our redirect?

--tracey



wget --server-response -O /dev/null http://www.archive.org/download/tdaonppodcast20enhV2/tdaonp_podcast20enhV2.m4a
--18:30:56-- http://www.archive.org/download/tdaonppodcast20enhV2/tdaonp_podcast20enhV2.m4a
=> `/dev/null'
Connecting to www.archive.org:80... connected!
HTTP request sent, awaiting response... 302 Found
2 Date: Tue, 21 Mar 2006 02:31:05 GMT
3 Server: Apache/1.3.33 (Debian GNU/Linux) PHP/5.0.4-0.4
4 X-Powered-By: PHP/5.0.4-0.4
5 Location: http://ia310326.eu.archive.org/0/items/tdaonppodcast20enhV2/tdaonp_podcast20enhV2.m4a
6 Connection: close
7 Content-Type: text/html; charset=iso-8859-1
8
Location: http://ia310326.eu.archive.org/0/items/tdaonppodcast20enhV2/tdaonp_podcast20enhV2.m4a [following]
--18:31:02-- http://ia310326.eu.archive.org/0/items/tdaonppodcast20enhV2/tdaonp_podcast20enhV2.m4a
=> `/dev/null'
Connecting to ia310326.eu.archive.org:80... connected!
HTTP request sent, awaiting response... 200 OK
2 Date: Tue, 21 Mar 2006 02:31:02 GMT
3 Server: Apache/1.3.33 (Debian GNU/Linux) PHP/5.0.4-0.7
4 Last-Modified: Fri, 17 Mar 2006 18:41:43 GMT
5 ETag: "a90-39ddaa0-441b02e7"
6 Accept-Ranges: bytes
7 Content-Length: 60676768
8 Keep-Alive: timeout=15, max=100
9 Connection: Keep-Alive
10 Content-Type: audio/mpeg
11

Reply to this post
Reply [edit]

Poster: noisepollution Date: Mar 21, 2006 4:36am
Forum: forums Subject: Re: Mime type returned prevents media enclosure

Ah, that might be it. i'll send your post to the people at feedburner (with your permission?) maybe they can tell if their feeds are burned from the first url or from the redirect.

I'll let you know their answer.

Thank's for all the support so far!

Henk.

Reply to this post
Reply [edit]

Poster: noisepollution Date: Mar 21, 2006 5:24pm
Forum: forums Subject: Re: Mime type returned prevents media enclosure

Thanks to the assistance of the feedburner team I now know what happens with the feed: it's not an issue with the m4a files or the redirect. It's seems to be a timing issue. Someimes the redirect takes to long for feedburner to process it. But there is a sollution within feedburner: resyncing. That way feedburner works out the media enclosures again, taking a bit more time. So I think we cracked it. Thanks very much for your help and I'll make sure to mention the great support of you guys on my next podcast!

greetz and thanks,
Henk.

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Mar 22, 2006 2:06am
Forum: forums Subject: Re: Mime type returned prevents media enclosure

Yaaaaaay!!

Thanks for helping us diagnose with good and timely feedback, too!

Enjoy!
--tracey

Reply to this post
Reply [edit]

Poster: noisepollution Date: Mar 22, 2006 3:24am
Forum: forums Subject: Re: Mime type returned prevents media enclosure

Glad to see that combined efforts work towards a sollution; without any commercial incentives, too. Sometimes this online community thing just works!

Hopefully some other people benefit from this thread as well.

Thx again,
henk.